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1Curve Fitting Overview
Chapter 1
cn1gepoOn2.points. Moetw.dgi9eriearOn2.
This chapter provides an introduction to curve fitting. It includes information on the following topics:

• The purpose of performing curve fits.

• The types of curve fits that are available in KaleidaGraph.

• Choosing an appropriate curve fit model.

1.1 Purpose of Curve Fitting
Curve fitting, also known as regression analysis, is used to find the "best fit" line or curve for a series of data 
points. Most of the time, the curve fit will produce an equation that can be used to find points anywhere along 
the curve. In some cases, you may not be concerned about finding an equation. Instead, you may just want 
to use a curve fit to smooth the data and improve the appearance of your plot. KaleidaGraph provides curve 
fits that can be used in both of these scenarios.

1.2 Types of Curve Fits
The curve fits included in KaleidaGraph can be divided into t.cnto ia suatc cugos of:  or curve for a series of6c 
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1.2.2 Nonlinear Curve Fits
Nonlinear curve fitting is accommodated in KaleidaGraph through the General curve fit function. Using this 
function, you can define your own equation or choose one from our library of over 100 curve fit definitions. 
This is the most powerful fitting option in KaleidaGraph because you can specify virtually any equation to 
be fitted to the data.

The General curve fit is based on the Levenberg-Marquardt algorithm and is calculated using an iterative 
procedure. KaleidaGraph starts with the initial guesses for the unknown parameters that were supplied with 
the equation. It then calculates a Chi Square value that represents the sum of the squared error between the 
original data and the calculated fit. During each iteration, KaleidaGraph varies the parameter values slightly 
and re-evaluates Chi Square until it finds the best fit.

Chapter 3 contains more information on the use of the General curve fit function. 

1.2.3 Smoothing Curve Fits
The smoothing fits in KaleidaGraph are different from the other two types of fits in that these curve fits do 
not generate an equation for the resulting curve. This is because there is no single equation that can be used 
to represent the curve. These curve fits are useful when you just want to improve the appearance of the plot 
by drawing a smooth curve through the data.

The four smoothing fits available in KaleidaGraph are: Smooth, Weighted, Cubic Spline, and Interpolate. 
Each one of these curve fits uses a different technique to arrive at the final curve, so you may want to apply 
more than one to see which one looks the best.

The Smooth and Interpolate curve fits are based on the same underlying technique, with the Smooth curve 
fit incorporating a geometric weight to arrive at the final curve. The Weighted curve fit uses the locally 
weighted Least Squares error (Lowess) method. The Cubic Spline curve fit is calculated using a series of 
cubic polynomials. Section 4.1 contains a description of each fit and Section 4.2 provides an example of 
applying a Cubic Spline curve fit.

1.3 Choosing a Curve Fit Model
Since KaleidaGraph provides a number of different curve fit types and over 100 General curve fit equations, 
choosing a model for a particular data set can be a difficult task. When you are deciding on a curve fit model, 
it helps to know some of the underlying properties associated with the data to make an educated decision on 
which model to use.

Depending on your field of study, you may find that certain equations or families of equations are used on 
a regular basis. For example, Sigmoidal curves are normally used to fit dose response data and Hyperbolic 
functions are normally used to fit ligand binding data in the field of enzyme kinetics.

If you do not know what type of curve fit to use, you may be able to ask a colleague or do some research to 
see what curve fits are normally used with the type of data that you have collected. If that proves to be 
fruitless or if nothing is known about the data, then the selection of the model must be based on the raw data.

You can use a Scatter plot to plot the data and see the general shape of the curve. The following figures 
provide a glimpse of the general shape associated with some of the more common families of General curve 
fits that are used in KaleidaGraph. Within each family, KaleidaGraph provides a number of different curve 
fit equations and it may take some trial and error to find the equation that produces the best results.
6 1.3  Choosing a Curve Fit Model
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2Using Least Squares Curve Fits
Chapter 2
This chapter provides information on the five Least Squares curve fits available in KaleidaGraph and 
includes an example of applying a Polynomial curve fit to a plot.

2.1 KaleidaGraph’s Least Squares Curve Fits

2.1.1 Linear
This function fits a straight line through your data, of the form y = m0 + m1 * x. There are no data restrictions 
associated with this curve fit.

Note: On a semi-log or log-log plot, this fit appears as a curved line.

2.1.2 Polynomial
This function fits a curve through your data, of the form y=m0 + m1 * x + m2 * x2 + m3 * x3 +...+ m9 * x9. 
The more complex the curvature of the data, the higher the polynomial order required to fit it. There are no 
data restrictions associated with this curve fit.

2.1.3 Exponential
This function fits a curve through your data, of the form y = m0 * em1 * x. It is generally used to fit data that 
increases or decreases at a high rate. This curve fit cannot fit negative data or data equal to zero.

Note: On a semi-log plot with a linear X axis, the curve appears as a straight line.

2.1.4 Logarithmic
This function fits a curve through your data, of the form y = m0 + m1 * log(x). A logarithmic curve fit is 
generally used with data that spans decades (100, 101, 102, and so on). This curve fit cannot be used to fit 
negative data or data equal to zero.

Note: On a semi-log plot with a linear Y axis, the curve appears as a straight line.

2.1.5 Power
This function fits a curve through your data, of the form y = m0 * xm1. This curve fit cannot be used to fit 
negative data or data equal to zero.

Note: On a log-log plot, the curve appears as a straight line.
2.1  KaleidaGraph’s Least Squares Curve Fits 9
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2.2 Applying a Least Squares Fit
The following steps explain how to apply a Least Squares fit, using the Polynomial curve fit as an example. 
10 2.2  Applying a Least Squares Fit





 
The KaleidaGraph Guide to Curve Fitting
12 2.2  Applying a Least Squares Fit



       
3Using Nonlinear Curve Fits
Chapter 3
This chapter provides information on the nonlinear curve fit available in KaleidaGraph. It also covers some 
basic concepts, including:

• Structuring the curve fit definition and initial guesses.

• Managing the master curve fit list.

• Using the predefined curve fit equations.

• Entering a custom curve fit definition.

• Applying a General curve fit.

• Using weights when applying a General curve fit.

3.1 Introduction to the General Curve Fit
This is the most powerful curve fit in KaleidaGraph. It takes a user-defined equation and uses it to fit a set 
of plotted data. Any function of x or m0, where either x or m0 is the independent variable, can be defined 
using up to nine parameters (m1–m9).

Examples:
m1 * m0
m1 + m2 * m0
m1 * exp(–m2 * m0)

When a General curve fit is selected, a curve, defined by the equation in the Curve Fit Definition dialog, is 
fitted to the data using the Levenberg-Marquardt algorithm. There are no data restrictions associated with 
this curve fit.
3.1  Introduction to the General Curve Fit 13
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3.2 General Curve Fit Basics
This section explains the structure of the curve fit equation, setting initial conditions for the parameters, the 
Curve Fit Definition dialog, and the use of the commands in the General submenu.

3.2.1 Curve Fit Definition
The curve fit definition is the equation that is fitted to the data. Curve fit definitions are composed of the 
same items as formulas in Formula Entry: operators, parameters, functions, and constants, in addition to an 
independent variable. When entering the curve fit definition, follow these guidelines:

• The independent variable in an equation is represented by m0.

• The parameters being calculated by the fit are represented by m1–m9. Parameters should be 
entered wherever you have an unknown quantity and you want KaleidaGraph to calculate the best 
value.

• Use an asterisk (*) for multiplication and a caret (^) for raising quantities to a power.

• KaleidaGraph does not distinguish between upper and lower case letters (m0 and M0 are the same).

• Constants and other shorthand references can be defined in the library for use in a curve fit 
definition. Some definitions in the default library are used to substitute x for m0, and a, b, c, and d 
for m1, m2, m3, and m4, respectively.

• To include a column number as part of the curve fit definition, the table function must be used. 
Section 3.3.5 shows how to use the table function in a General curve fit definition. This method 
also enables you to fit equations containing multiple independent variables.

The following table lists some equations and how they appear as curve fit definitions in KaleidaGraph.

Original Equations Curve Fit Definitions

a * x + b m1 * m0 + m2

a + b * x^c m1 + m2 * m0^m3

a + b * exp(–c * x) m1 + m2 * exp(–m3 * m0)

a * exp(–b * x) * cos(c * x + d) m1 * exp(–m2 * m0) * cos(m3 * m0 + m4)
14 3.2  General Curve Fit Basics
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3.2.2 Initial Conditions
Even though KaleidaGraph calculates values for unknown parameters, you must supply an initial value for 
each parameter. The algorithm used to calculate the final results requires a reasonable guess to point it in the 
right direction. KaleidaGraph improves upon these values during each iteration of the fit.

Note: Since the fit starts with initial guesses and improves upon them with each iteration, the final values 
may be different for a separate set of initial guesses.

Do not get carried away trying to find good guesses; the initial conditions are just that, guesses. If you are 
not sure what the guesses should be, keep the initial conditions non-zero, and at the correct order of 
magnitude that you might expect (be it 0.001, 1, or 1000).

The initial conditions are entered immediately following the curve fit definition. Place a semicolon at the 
end of the definition and begin entering the initial guesses, separating each with a semicolon. The table 
below shows the definitions from the previous section with some sample initial guesses.

3.2.3 Curve Fit Definition Dialog
The Curve Fit Definition dialog is used to enter the equation, initial guesses, and allowable error to be used 
in the curve fit. You can also choose to specify partial derivatives or to weight the data.

This dialog can be displayed using either of the following methods:

• Choose a curve fit from the General submenu (Curve Fit menu). In the dialog that is displayed, 
click Define.

• Choose Curve Fit > Edit General. In the dialog that is displayed, select the name of a curve fit 
and click Edit.

Curve Fit Definitions with Initial Guesses

m1 * m0 + m2; m1 = 0.5; m2 = 23

m1 + m2 * m0^m3; m1 = –2; m2 = 3; m3 = 2

m1 + m2 * exp(–m3 * m0); m1 = 5; m2 = 1; m3 = 0.5

m1 * exp(–m2 * m0) * cos(m3 * m0 + m4); m1 = 4; m2 = 0.7; m3 = 2.2; m4 = 15
3.2  General Curve Fit Basics 15
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Figure 3-2  Expanded Curve Fit Definition dialog

The nine buttons at the bottom of the dialog allow each partial derivative to be entered in the text field 
above the buttons. The biggest advantage of specifying the partial derivatives is accuracy. The curve fit 
algorithm uses these partial derivatives to direct itself where to move after each iteration to find the best 
solution.

You can choose to specify only some of the partial derivatives, but not all of them. It is better to let 
KaleidaGraph approximate the partial instead of specifying the wrong derivative. If a partial derivative 
is missing, KaleidaGraph numerically approximates that partial derivative.

5. Degrees/Radians Buttons
These buttons determine whether the results of trigonometric functions are in degrees or radians.

6. Help...
Click this button to display the Help dialog.

7. File...
Clicking this button displays a text editor that can be used to create, open, or save a curve fit definition. 
The definition appears on the first line and any partial derivatives appear on the lines below it.
3.2  General Curve Fit Basics 17
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3.2.4 Managing the Curve Fit List
KaleidaGraph maintains a master list of curve fits in the General submenu. This submenu can store up to 
16 user-defined equations that can be applied whenever a new plot is created.

The following sections explain how to edit and save changes to the curve fits listed in the General submenu.

Note: The only way to edit the master list is to create a new plot and use the Edit General command. The 
master list is not affected if you do either of the following:

• Use a saved plot (or any plot that had its data archived).

• Choose a curve fit from the General submenu and click Define to edit the definition.

Adding a Curve Fit to the Master List
To add a curve fit to the master curve fit list:

1. Create a new plot.

2. Choose Curve Fit > General > Edit General. The dialog in Figure 3-3 appears.

Figure 3-3  Edit General dialog

3. Select a fit in the current list.

4. Click Add and a New Fit appears below the selected fit in the list. The name of the fit can be 
changed by selecting it and editing the name in the text field.

5. Click Edit to enter the definition in the Curve Fit Definition dialog.

6. Click OK when you are finished. Now you can use this fit in the active plot or any new plots that 
are created. Remember to save changes to the Macros file to make the changes permanent.
18 3.2  General Curve Fit Basics
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Rearranging the Master Curve Fit List
To rearrange the curve fit list:

1. Create a new plot.

2. Choose Curve Fit > General > Edit General.

3. Select the curve fit to be repositioned.

4. Click Copy to copy the fit to the trash bin.

5. Click Remove to delete the name from the listing.

6. Select a curve fit in the current list.

7. Select the name of the curve fit that was copied to the trash bin.

8. Click Add and the curve fit appears below the selected fit in the list.

Note: When rearranging curve fits, do not leave the Edit General dialog until you are completely finished. 
As soon as you click OK or Cancel in this dialog, anything in the trash bin is deleted. The only 
permanent trash bin item is New Fit.

Removing a Curve Fit from the Master List
To remove a curve fit from the master list:

1. Create a new plot.

2. Choose Curve Fit > General > Edit General.

3. Select the curve fit to be deleted.

4. Click Remove to delete the curve fit from the listing.

5. Click OK.
3.2  General Curve Fit Basics 19
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3.3 Using the General Curve Fit
This section explains how to define and apply a General curve fit equation. Other topics include weighting 
3.3  Using the General Curve Fit 21
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5. Click Edit to display the Curve Fit Definition dialog.

6. Click File in the Curve Fit Definition dialog. A text editor appears.

7. Choose File > Open.

8. Locate and open a curve fit definition from the Curve Fits folder. The definition and initial guesses 
for the parameters will be displayed in the editor.

9. Choose File > Close to display the curve fit equation in the Curve Fit Definition dialog. Make sure 
you change the initial guesses, because all of the initial guesses are set equal to 1.0 by default.

10. Click OK until you return to the plot window. Now you can use this fit in the active plot or any 
new plots that are created. Remember to save changes to the Macros file to make the changes 
permanent.

Importing Definitions from a Macros File
The Macros folder contains a Macros file for each category of curve fit definitions. Importing one of these 
Macros files loads the curve fit definitions into the General submenu.

Note: If a plot is already open, you will not see the imported curve fit definitions until a new plot is created.

To load the definitions from a Macros file:

1. Choose 
22 3.3  Using the General Curve Fit
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3.3.2 Entering a Custom Curve Fit Definition
If you need to use a curve fit equation that is not included with the predefined equations, you can easily enter 
a custom equation and use it in KaleidaGraph.

Note: Custom curve fit equations can also be defined in the library. Refer to the KaleidaGraph manual or 
online help for more information.

To create a custom curve fit definition (and have it available for all future plots):

1. Create a new plot.

2. Choose Curve Fit > General > Edit General.

3. Select a fit in the current list.

4. Click Add and a New Fit appears below the selected fit in the list. The name of the fit can be 
3.3  Using the General Curve Fit 23
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3.3.3 Applying a General Curve Fit
To apply a General curve fit:

1. Open the plot window which will have the curve fit applied. Figure 3-6 shows a sample plot.

Figure 3-6  Sample plot

2. Choose a curve fit from the General submenu (Curve Fit menu). A Curve Fit Selections dialog 
similar to Figure 3-7 appears. All dependent variables are listed under Column Names.

Figure 3-7  Curve Fit Selections dialog

3. If the equation has not been entered, click Define to enter the equation or shorthand reference to 
be applied to the data. Figure 3-8 shows the Curve Fit Definition dialog containing a curve fit 
definition. When you are finished, click OK.

Note: For information on including this fit in your master curve fit list, refer to Section 3.2.4.
24 3.3  Using the General Curve Fit
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Figure 3-8  Curve Fit Definition dialog

4. Click the check box of each variable to be fit. Typing Ctrl+A (Windows) or +A (Macintosh) 
selects all of the variables at once.

5. Click OK to apply the curve fit. A status dialog will show the progress of the curve fit. It is updated 
after each iteration.

Note: Typing Ctrl+Period (Windows) or +Period (Macintosh) cancels a General curve fit. 
The current state of the fit is calculated and the resulting curve is drawn.

When the curve fitting process is complete, the curve is drawn on the plot. Once the curve fit is 
applied, you can display its equation or extrapolate the fit to the axis limits. These are a few of the 
features covered in Chapter 6 of this guide. Figure 3-9 shows the sample plot after applying a 
General curve fit (represented by the dashed line) and displaying the equation.

Figure 3-9  Sample plot with General curve fit applied
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3.3.4 Weighting Data
The General curve fit provides an option to weight the data. When Weight Data is selected in the Curve Fit 
Definition dialog, the data is weighted during the curve fit. These weights are taken from a specified column 
in the data window. The weights should represent the individual error values of the fitted data.

Each weight is used internally as: 1/(weight^2). Specifying a weight less than 1.0 for a data point increases 
the internal weight of that point and can make the total error much larger. Weight values larger than 1.0 
reduce the internal weights. When Weight Data is not selected, a weight value of 1.0 is used for all data 
points.

When the Weight Data option is selected and you choose a variable to fit, the dialog in Figure 3-10 appears. 
Use this dialog to select the column containing the weights for your data.

Figure 3-10  Selecting column of weights

3.3.5 Fitting Equations with Multiple Independent Variables
Through the use of the table function, KaleidaGraph can fit equations containing multiple independent 
variables. For example, to fit an equation like y = a*x + b*x2 +c, you would enter the following curve fit 
 Tm
-0.03ofweight^2). Specifying a weir. .1108 0aeosele03ofw4r8a.
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3.3.6 Setting Limits for Curve Fit Parameters 
3.3  Using the General Curve Fit 27
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4Using Smooth Curve Fits
Chapter 4
This chapter provides information on the four smoothing curve fits available in KaleidaGraph and includes 
an example of applying a Cubic Spline curve fit to a plot.

4.1 KaleidaGraph’s Smooth Curve Fits

4.1.1 Smooth
This function fits a smoothed curve to the data. KaleidaGraph starts by applying a Stineman function to the 
data. The output of this function then has a geometric weight applied to the current point and ±10% of the 
data range, to arrive at the smoothed curve.

The only data restriction associated with this curve fit is that the independent (X) variable must be in 
ascending order in the data window. There is no single expression that represents this curve; therefore, there 
are no parameters to view or copy.

4.1.2 Weighted
This function fits a curve to the data, using the locally weighted Least Squared error (Lowess) method. The 
result of this curve fit is to plot a best fit smooth curve through the center of the data. This is an extremely 
robust fitting technique. Unlike the standard Least Squared error method, this technique is nearly insensitive 
to outliers. However, this does not come for free. The Weighted curve fit is computationally complex and 
can take a very long time for a large data set.

The only data restriction associated with this curve fit is that the independent (X) variable must be in 
ascending order in the data window. There is no single expression that represents this curve; therefore, there 
are no parameters to view or copy.

4.1.3 Cubic Spline
Moving left to right along the curve in increasing X, every group of four consecutive data points defines a 
cubic polynomial equation. A series of these cubic polynomials connected together define a cubic spline 
curve. Using this curve fit is similar to using a French curve to connect all of the data points.

The only data restriction associated with this curve fit is that the independent (X) variable must be in 
ascending order in the data window. There is no single expression that represents this curve; therefore, there 
are no parameters to view or copy.
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4.1.4 Interpolate
This function fits a curve that passes through the data points and matches the slopes at those points. The 
advantage of this curve fit is that it does not produce wild results near an abrupt change of slope, as can 
happen with the Cubic Spline curve fit.

The only data restriction associated with this curve fit is that the independent (X) variable must be in 
ascending order in the data window. There is no single expression that represents this curve; therefore, there 
are no parameters to view or copy.

4.2 Applying a Smoothing Fit
The following steps explain how to apply a smoothing fit, using the Cubic Spline curve fit as an example. 
The procedure is basically the same for applying the other smoothing fits.

To apply a Cubic Spline curve fit:

1. Open the plot window which will have the curve fit applied. Figure 4-1 shows a sample plot.

Figure 4-1 Sample plot

2. Choose Curve Fit > Cubic Spline. A Curve Fit Selections dialog similar to Figure 4-2 appears. 
All dependent variables are listed under Column Names.

Figure 4-2  Curve Fit Selections dialog
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3. Click the check box for each variable to be fit. A keyboard shortcut (Ctrl+A under Windows or 
+A on a Macintosh) is available to select all of the variables at once.

Note: When applying a Weighted fit, a second dialog appears each time a variable is selected. Use 
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5Working with Curve Fit Results
Chapter 5
This chapter explains how to:

• View the results of a curve fit.

• Interpret the values that are reported by KaleidaGraph.

• Export the curve fit results for further analysis.

• Obtain values from the curve fit line using Formula Entry.

5.1 Viewing Curve Fit Results
KaleidaGraph provides two methods to view the results of a curve fit. You can either display the equation 
on the plot or view the coefficients in a dialog.

5.1.1 Displaying the Curve Fit Equation
The curve fit equation can be displayed by turning on Display Equation in the Plot menu. The results from 
any General, Linear, Polynomial, Exponential, Logarithmic, or Power curve fits are displayed in the plot 
window. Not only is the resulting equation displayed, but if any updates occur to the curve fit, the equation 
updates automatically.

Depending on the type of curve fit, the equation is displayed in a table or as a text label. The General and 
Polynomial curve fits display equations in a table because the equations for these fits can be much longer 
than the others. The appearance of the equation can be edited by double-clicking it with the Selection Arrow.

The numeric format of the equation can be controlled using the Equation Label Format command (Format 
menu). Some of the options available include number format, number of significant digits, and trailing zeros.
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5.1.2 Viewing Coefficients
The other method of displaying curve fit results is to view the curve fit’s coefficients in a dialog.

To view the coefficients from the curve fit:

1. Reselect the curve fit from the Curve Fit menu. A Curve Fit Selections dialog similar to Figure 5-1 
appears with a drop-down arrow under View for each variable that has a curve fit applied.

Figure 5-1 Curve Fit Selections dialog

2. Click one of the drop-down arrows and choose View Results from the pop-up menu that appears. 
A dialog similar to Figure 5-2 will be displayed containing the coefficients from the curve fit.

Figure 5-2  Viewing coefficients

3. To copy the coefficients to the Clipboard, click Clipboard. This enables you to paste the results 
into another window or program.

4. To copy the coefficients to the Calculator, click Calculator. This enables you to use the results in 
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5.3 Exporting Curve Fit Results
Once a curve fit has been applied, the results of the fit can be exported for further analysis. The export 
options include copying the parameter values to the Clipboard or the Calculator, copying the values of the 
curve fit line into the data window, and copying the residual values into the data window.

5.3.1 Copying the Parameters to the Clipboard or Calculator
To copy the parameter values to the Clipboard or Calculator:

1. Reselect the curve fit from the Curve Fit menu. A Curve Fit Selections dialog similar to Figure 5-3 
appears with a drop-down arrow under View for each variable that has a curve fit applied.

Figure 5-3  Curve Fit Selections dialog

2. To copy the coefficients to the Clipboard, click one of the drop-down arrows and choose Copy 
Parameters to Clipboard from the pop-up menu that appears. This enables you to paste the results 
into another window or program.

Note: If you paste the results into the plot window, the coefficients in the table do not change if 
the curve fit is updated. For this reason, we recommend that you use the Display Equation 
command instead.

3. To copy the coefficients to the Calculator, click one of the drop-down arrows and choose Copy 
Parameters to Calculator from the pop-up menu that appears. This enables you to use the results 
in a Formula Entry function.

4. Click OK to return to the plot window.

Note: It is also possible to copy the parameters by choosing View Results from the pop-up menu and 
clicking the Clipboard or Calculator button.
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5.3.2 Copying the Curve Fit Values to the Data Window
To copy the values of the curve fit line to the data window:

1. Reselect the curve fit from the Curve Fit menu. A Curve Fit Selections dialog similar to Figure 5-3 
appears with a drop-down arrow under View for each variable that has a curve fit applied.

2. Click one of the drop-down arrows and choose Copy Curve Fit to Data Window from the pop-
up menu that appears.

3. Click OK to return to the plot window.

KaleidaGraph will append the results after any existing data in your data window. The first column will be 
a series of X values. Except for the Weighted curve fit which uses the original X values, the number of X 
values will be equal to the number of curve fit points specified in the Curve Fit Options dialog (Format 
menu). The second column will contain the values from the curve fit at each of these locations.

Note: If you want to use the original X values or supply your own X values, you need to use Formula Entry 
to calculate the curve fit values. Section 5.4 provides instructions for using the curve fit functions in 
Formula Entry to obtain values from the curve fit.

5.3.3 Copying the Residuals to the Data Window
To copy the residual values to the data window:

1. Reselect the curve fit from the Curve Fit menu. A Curve Fit Selections dialog similar to Figure 5-3 
appears with a drop-down arrow under View for each variable that has a curve fit applied.

2. Click one of the drop-down arrows and choose Copy Residuals to Data Window from the pop-
up menu that appears.

3. Click OK to return to the plot window.

KaleidaGraph will append the residual values after any existing data in the data window. These values 
represent the difference between the original Y values and the values calculated by the curve fit.
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To calculate values from a curve fit:

1. Activate the data window that contains the fitted variables. Figure 5-5 shows a portion of the data 
used to create the sample plot.

Figure 5-5  Data used to create sample plot

2. Choose Windows > Formula Entry.

3. Enter the formula into the window. Figure 5-6 shows the formula for this example. The formula 
should be of the form z = fit(x,y), where:

z is the destination column.
x is either a single data value or a column containing X values.
y is the column that had the curve fit applied.
fit is replaced by the appropriate command from the Curve Fits menu of Formula Entry.
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Figure 5-7  Data window containing curve fit values

Note: This method uses the curve fit points originally calculated when the fit was applied. You may want 
to increase the number of calculated points to make the values from the fit more accurate. See 
Section 6.5 for instructions on increasing the number of curve fit points.

5.4.2 Using the Calculated Equation to Find Values
The most accurate method of getting values from a fit is to use the original equation and the parameters 
calculated by KaleidaGraph. This is not possible when a Smooth, Weighted, Cubic Spline, or Interpolate 
curve fit is applied to the data, because these curve fits do not result in an equation.

To calculate values using the curve fit’s equation:

1. Copy the curve fit coefficients to the Calculator. Refer to Section 5.3.1 if you are unsure of how to 
do this. If you applied a General curve fit, you can skip this step because the parameters are 
automatically stored in the Calculator.

2. Activate the data window that contains the fitted variables. Figure 5-8 shows the original data with 
a column containing new X values (column 2).

Figure 5-8  Data window containing new X values
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3. Choose Windows > Formula Entry.

4. Enter your formula into the window. Figure 5-9 shows the formula used to obtain values from a 
curve fit at designated points, where:

c3 is the destination column for the curve fit values.
c2 is the column containing the new X values.
m0–m5 are the curve fit coefficients previously copied to the Calculator.

Figure 5-9  Using the curve fit equation to calculate values

5. Click Run to execute the formula. The destination column is filled with the values of the curve fit 
at the specified X values. Figure 5-10 shows the resulting data window, with the curve fit values 
in the last column (column 3).

Figure 5-10  Data window containing curve fit values

Note:
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6Other Curve Fit Features
Chapter 6
This chapter explains how to:

• Change the appearance of the curve fit.

• Display just the curve fit line on the plot.

• Extrapolate a curve fit to the axis limits.

• Force a Linear fit through the origin.

• Increase the number of curve fit points.

• Remove a curve fit.

6.1 Changing Appearance of Curve Fit Lines
To change the line style, width, or color of curve fit lines:

1. With the plot window active, choose Plot > Plot Style.

2. Select the variable to be edited.

3. Click Curve Fit to make changes to the curve fit line.

4. To change the line style, select a different option from the Style column. Choose None from this 
list to hide the line. The current style is preceded by a check mark.

5. To change the line width, select a different option from the Width column. The current width is 
preceded by a check mark.

6. To change the color, select a different color from the palette. The current color has a white square 
around it.

7. Click OK to return to the plot.
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6.2 Displaying Only the Curve Fit
There may be times when you are only interested in displaying the curve fit on the plot without the original 
data points. This can be accomplished using the Plot Style dialog, provided the plot is not a Scatter plot.

To display only the curve fit:

1. With the plot window active, choose Plot > 
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6.6 Removing a Curve Fit
Curve fits can be removed from a plot in the same way that they are added. After applying a curve fit, a check 
mark appears next to that type of fit in the Curve Fit menu to indicate that a curve fit is applied.

To remove a curve fit from the plot:

1. From the Curve Fit menu, choose the type of curve fit to be removed. A dialog similar to 
Figure 6-2 is displayed containing the list of variables. The check box of each fitted variable is 
selected.

Figure 6-2  Curve Fit Selections dialog

2. Clear any check boxes for the fits to be removed. Clicking Deselect clears all of the check boxes 
at once.

3. Click OK to return to the plot and remove the curve fits and any associated equations.

Appendixes
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Not getting the correct results when typing the results of a curve fit into a formula.
By default, the results of a curve fit are displayed with five significant digits. You can obtain more accuracy 
by choosing Format > Equation Label Format and increasing the number of digits or decimals. This will 
make the results of your formula more accurate.

Another solution is to copy the results of the curve fit to the Calculator. These values are always stored as 
double precision numbers. See Section 5.3.1 for more information on copying the results to the Calculator.
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BReference Information
Appendix B
This chapter provides information on the methods and equations used when performing regression analysis 
in KaleidaGraph.

B.1 Curve Fit References
General Curve Fit
Press, W. H., Flannery, B. P., Teukolsky, S. A., and Vetterling, W. T. Numerical Recipes in C. Cambridge 
University Press, New York (1988).

Linear, Polynomial, Exponential, Logarithmic, and Power Curve Fits
Beyer, W. H. Standard Mathematical Tables. CRC Press, Cleveland (1976).

Smooth Curve Fit
Stineman, R. W. A consistently well-behaved method of interpolation. Creative Computing, July (1980).

Weighted Curve Fit
Chambers, J. M., Cleveland, W. S., Kleiner, B., and Tukey, P. A. Graphical Methods for Data Analysis. 
Duxbury Press, Boston (1983).

Cubic Spline Curve Fit
Press, W. H., Flannery, B. P., Teukolsky, S. A., and Vetterling, W. T. Numerical Recipes in C. Cambridge 
University Press, New York (1988).

Interpolate Curve Fit
Stineman, R. W. A consistently well-behaved method of interpolation. Creative Computing, July (1980).
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curve fits to Curve Fit menu 18
curve fits to saved plots 20
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limiting parameters 27
line style 43
line width 43
multiple independent variables 26
removing 46
viewing coefficients 34
weighting data 26

D
data windows

copying curve fit values into 37
copying residuals into 37

defining custom curve fit equation 23
Display Equation command 33
Display R^2 instead of R check box 35
displaying

curve fit coefficients 34
curve fit equations 33

E
Edit General command 18–21
editing

curve fit color 43
curve fit equations 33
curve fit line style 43
curve fit line width 43
master curve fit list 18
variable color 43
variable line style 43
variable line width 43

entering custom curve fit definition 23
Equation Label Format command 33
equations

Chi Square 35, 50
General curve fit 50
R 50
See also curve fit equations

errors, General curve fit results 35
Exponential curve fit

data restrictions 9
description 9
function 9
reference 49

Extrapolate Fit to Axis Limits check box 44
extrapolating curve fits 43
52
F
Force Line fit through zero check box 45
Formula Entry, calculating values from a fit 38–41

G
General curve fit 14–27

adding a new fit 18
adding fits to saved plots 20
affect on Macro Calculator 27
applying 24–25
Chi Square 35
constructing equation 14
Curve Fit Definition dialog 15
curve fit equation 14
description 13
entering custom curve fit definition 23
equations 50
importing definitions 21–22
importing definitions from a text file 21
importing library definitions 22
initial conditions 15
limiting parameters 27
master curve fit list 18
multivariate fits 26
parameter errors 35
predefined equations 21–22
rearranging a curve fit 19
reference 49
removing a curve fit definition 19
saving changes 20
specifying partial derivatives 16
weighting data 26

General submenu 18–22

I
importing curve fit definitions 21–22
increasing number of curve fit points 45
initial conditions 15
Interpolate curve fit

data restrictions 30
description 30
reference 49

L
Least Squares curve fitting 5
Levenberg-Marquardt algorithm 6, 13
Library command 22
library, importing curve fit definitions 22
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limit() function 27
limits on parameters 27
line style

curve fit 43
variable 43

line width
curve fit 43
variable 43

Linear Correlation Coefficient 35
Linear curve fit

applying to log/semi-log scales 48
description 9
forcing through origin 45
function 9
reference 49

Logarithmic curve fit
data restrictions 9
description 9
function 9
reference 49

M
Macro Calculator 27
macro files, saving curve fit changes 20
master curve fit list 18–20
memory registers 27
multiple independent variables 26
multivariate fits 26

N
nonlinear curve fit 6

O
obtaining values from a curve fit 38
origin 45

P
parameter

errors 35
limits 27

Polynomial curve fit
applying 10–11
description 9
function 9
reference 49

Power curve fit
data restrictions 9
description 9
function 9
reference 49

predefined curve fit definitions 21–22

R
R 35
R equation 50
R2 35
rearranging the master curve fit list 19
removing

curve fit 46
curve fit from master list 19

residuals 37

S
saving changes to Curve Fit menu 20
setting limits on parameters 27
Smooth curve fit

data restrictions 29
description 29
reference 49

Specify Partials check box 16

T
table() function 26

V
variable

color 43
line style 43
line width 43

viewing coefficients 34

W
Weight Data check box 16, 26
Weighted curve fit

data restrictions 29
description 29
reference 49

weights 16
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